IIS Authentication

Jun 29, 2009 at 7:08 PM

Hi, im sorta new with web setups. But is there a way with WAI to make the default authentication of a particular folder Windows Authentication and leave the rest Anonymous?

Any help would be greatly appriciated

Jun 29, 2009 at 11:03 PM

I actually figured this out but now im stuck on another issue. Is there any way to make a new App Pool or do I just have to make a new Dialog and do it myself?

Jun 30, 2009 at 9:32 AM

Hi 4amm3r,

The WebappPool creation is already in the template, i.e. by default the webapp you install via this template creates its own app pool it'll run in.
You can see the app pool setting in the *.wxs template: If you open the the wxs project in wixedit go to files -> expand e.g. NewWebsiteConfigPHP->iis:WebSite->iis:WebAppPool
The webappPool here is mapped to the website via the name property in the iis:WebApplication entry above (->iis:WebSite->iis:WebApplication->WebAppPool)

(BTW: I figured out a bug in the Template for Windows Vist/2008 (NewWebSitePHPIIS7FCGI) - the iis:WebApplication entry is missing. -> going to fix that soon)

hth,
Bernhard

Jul 6, 2009 at 5:03 PM

Hey,

Thanks for the help, I got the installer to make a new AppPool with a name given at one of the dialog screens. I have also got half way in allowing the installer to use an existing AppPool. I made a vbs script to get the AppPools that exist in IIS. Similar to the existing web sites i have them show in a ComboBox. I am trying to do the similar thing as the Make a new website/ Use an existing Website component where when installing I can choose to use an existing AppPool and it doesn't try to make a new one(Which is what it is currently trying to do and then the install fails).

So far I made a new component:

<Component Id="NewWebsiteOldAppPoolConfigASP" Guid="E6605AB2-CA03-4A78-AE66-D4B9BEF4307A" NeverOverwrite="yes">

then in that compnent when I add the Web application I am stumped on what to put for a WebAppPool:

<iis:WebApplication Id="WebApplicationOldAppPool" Name="[WEBAPPLICATIONNAME]" WebAppPool="WebAppPoolOldAppPool">
</iis:WebApplication>

</iis:WebSite>
Right now I am just doing this: (This as you can probably tell, makes a new appPool and trys to overwrite an existing appPool)

  <iis:WebAppPool Id="WebAppPoolOldAppPool" Name="[WEBAPPLICATIONPOOLNAME]"/>

Here are 2 images that may help with understanding what I am trying to do if i am still not clear enough:

http://i5.photobucket.com/albums/y163/4amm3r/installer1.png

http://i5.photobucket.com/albums/y163/4amm3r/installer2.png

I hope this makes sense on what I am doing here and what my goal is. Any help with this would be greatly appriciated!

Thanks

Jul 13, 2009 at 3:18 PM

Hi 4amm3r,

Sorry for the late replay.

Can you post me your wxs file?

I’ll have a look into it tomorrow.

Thx.

Bernhard

Jul 13, 2009 at 8:56 PM

Hey,

Thanks that would be awesome.

I tried adding it as a code snippet, but it crashed my firefox...

Heres the link for the file

http://www.4shared.com/get/117855060/8fa4d0ea/WXSForHelp.html

What I have implemented already:

-Admin Folder is Windows Authenticated

-Screen to use existing or make a new AppPool

-Ability to make a new AppPool

What I want to have implemented:

-Use an Existing App Pool

 

Jul 16, 2009 at 11:27 AM

Hi 4amm3r,

just a quick question – what is the error message you get?

Thanks,

Bernhard

Jul 16, 2009 at 4:47 PM

Hey,

So just to restate, i can install perfectly fine making a new AppPool thats not already existing. However, when i use an existing one, it gives me this error:

http://i5.photobucket.com/albums/y163/4amm3r/error.png

"Failed While Processing WebDirs. (-2147024894 )"

Thanks Again!

Jul 17, 2009 at 1:27 PM

Hi 4ammr,

managed to get it work. Sending you separate email with modified wxs file.

I am planning to make some updates to the template (>2.0.13) – so that other people have already half of the work done.

Let me know if this works for you.

Hth,

Bernhard

Jul 17, 2009 at 4:30 PM

Hey,

Thanks a ton!

Sadlly I get a 404 error when i try and get any of the files...

http://i5.photobucket.com/albums/y163/4amm3r/erro404r.png

this happens in both IE and Firefox and when i try to "save target as", it says it cannot download the file from the server.

Ill keep trying incase it may just be having a server issue at the moment, but i don't know. Im not in that much of a hurry.

Thanks Again!

 

Jul 20, 2009 at 8:45 AM

Hi 4ammr,

sorry my fault. Try now remove the .xml after download.

Hth,

Bernhard

Jul 20, 2009 at 5:02 PM

Hey,

So I install and it now gives me a different error when I use an existing App Pool:

http://i5.photobucket.com/albums/y163/4amm3r/apppoolproblem.png

"Failed to create metabase key. (-2147024883 /W3SVC/AppPools/2 (ID:TestExistingAppPool)/ )"

Did you have any ideas why this could happen?

Also, does this:

<PublishFeatures>ALLOWADDREMOVEPROGRAM="1"</PublishFeatures>
      <RegisterProduct>ALLOWADDREMOVEPROGRAM="1"</RegisterProduct>
      <PublishProduct>ALLOWADDREMOVEPROGRAM="1"</PublishProduct>
      <RegisterUser>ALLOWADDREMOVEPROGRAM="1"</RegisterUser>

adds the Unistallation Implementation at all? It looks different than the previous:

<PublishFeatures Suppress="yes">0</PublishFeatures>
      <RegisterProduct Suppress="yes">0</RegisterProduct>
      <PublishProduct Suppress="yes">0</PublishProduct>
      <RegisterUser Suppress="yes">0</RegisterUser>
Thanks Again!

Jul 21, 2009 at 9:32 AM

Hi 4ammr,

hmm. My assumptions:

I have seen translations to “the data is invalid” for error with code -2147024883 (hex 8007000d)

If I look at the string in the dialog :

“/W3SVC/AppPools/2 (ID:…..)”

This doesn’t look like a valid Application pool string for me.

appPools strings I have seen look like this

“/W3SVC/AppPools/TestExistingAppPool”

I used the following vbs script to retrieve the app pool information:

http://chicago270.server4you.de/4ammr/getAppPools.vbs.txt

I would try to rebuild your package with this vbs script and see if this works.

Hth,

bernhard

Jul 21, 2009 at 9:37 AM

Forgot something,

The uninstall feature can now be controlled via the ALLOWADDREMOVEPROGRAM Property

ALLOWADDREMOVEPROGRAM = 1

Entry in Add/Remove Programms will be generated. Values like sitename, applicationpoolname, IP, Port, Directory will be stored in the registry during install -> as need this information later for identifying the site to remove.

Does not allow multiple installations, i.e. you can install the website only once per machine.

ALLOWADDREMOVEPROGRAM = 0

Behavior like before. No removal. No registry entries but allows multiple installations.

Hth,

bernhard