0
Vote

Feature: Update CheckForAjax functionality - either ajax extensions or .net 3.5

description

Und dann habe ich bei Umbraco4 noch folgende Frage: Umbraco läuft entweder mit .NET2+ajax extension oder mit .NET3.5 (ohne die Extension). Je nach Version braucht es jedoch eine andere web.config. Der bisherige CheckForAjax prüft aber lediglich ob die Ajax-Extension installiert ist, schlägt also bei einem .NET 3.5 fehl. Das könnten wir umgehen indem wir die checkAjax-Methode anpassen und sagen wenn das .NET Framework-Version größerGleich 3.5 ist dann ist es auch ok. Aber wie könnten wir je nach Version verschiedene Web.configs verwenden, da kenne ich mich mit wix-bedingungen net so aus…
Notfalls müssen wir uns hier eben vorerst auf .NET2 beschränken oder alternativ 2 verschiedene Pakete machen, ich weiss ja auch nicht welche .NET Versionen auf den 1&1 servern i.d.R. installiert sind.

comments